Slowness in application

Incident Report for Nmbrs

Resolved

We will perform an etra update tonight to combat the overall slowness experienced in the application.
Posted Jan 15, 2026 - 20:28 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2026 - 12:52 CET

Update

We are continuing to investigate this issue.
Posted Jan 15, 2026 - 12:21 CET

Update

We are continuing to investigate this issue.
Posted Jan 15, 2026 - 12:16 CET

Investigating

We have received a notion of slowness in our application. We are investigating the root cause of this matter and will update this incident as soon as possible
Posted Jan 15, 2026 - 11:31 CET
This incident affected: Nmbrs Netherlands (Web Application (APM), Sandbox, API), Nmbrs Hire (Nmbrs Hire), Nmbrs Perform (Nmbrs Perform), Nmbrs Expense (Nmbrs Expense), and Nmbrs Engage (Nmbrs Engage).