Expense not accessible

Incident Report for Nmbrs

Resolved

Incident has been closed
Posted Apr 01, 2025 - 16:43 CEST

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 15:57 CEST
This incident affected: Nmbrs Expense (Nmbrs Expense).